Delphi > Mobilní vývoj

Delphi 11 a starší verze Androidu

(1/1)

vandrovnik:
Ahoj,

u Delphi 11 píšou, že podporuje Android od verze 8.1. To je pro mne poměrně nepříjemné, protože pár zákazníků má mobilní zařízení se čtečkou čárových kódů, na kterých je Android 6 a Android 7. Na rozdíl od mobilních telefonů, kde ta obměna je rychlá, u těchto zařízení se s obměnou moc nepočítá (navíc pořizovací cena přes 30.000 Kč, to prostě není spotřební zboží).

Dá se aplikace z Delphi 11 nějak oficiálně přiohnout, aby fungovala i na Androidu 6? Třeba že by stačilo nějaké věci nepoužívat?
Od listopadu je nutné aplikace v Google Play mít pro cílovou verzi API 30 - to umí myslím až Delphi 11. Ovšem pokud zároveň chci mít i aplikaci pro Android 6, je to problém...

Díky, K.

Radek Červinka:
No můžeš jim dat balíček sám bez googlu, myslim, že jinak to nedáš.

vandrovnik:

--- Citace: Radek Červinka  14-09-2021, 10:37:22 ---No můžeš jim dat balíček sám bez googlu, myslim, že jinak to nedáš.

--- Konce citace ---

No, nechám si to jako nouzové řešení, přeci jen v Google Play je to jednodušší - instalace i následné aktualizace.

Je nějaký zásadní důvod, proč Delphi už nepodporují ty starší verze Androidu?

Radek Červinka:
Nevím, ale muzes zkusit upravit AndroidManifest.template.xml a nahradit %minSdkVersion% na absolutni cislo, tj. neco jako

--- Kód: ---<uses-sdk android:minSdkVersion="23" android:targetSdkVersion="29" />

--- Konec kódu ---

a dat vedet.

Navigace

[0] Seznam témat

Přejít na plnou verzi